Modulo de Aprendizagem |
Digitalizar fotografias para a base de dados do SFEUP

Notas:

No decorrer deste modulo de aprendizagem, pressupde-se que o utilizador ja
tem o scanner devidamente instalado no computador.

A versdo do Photoshop utilizada é a5.5.

1) Configurar o Photoshop para digitalizar imagens

O Photoshop pode digitalizar uma imagem a partir do scanner
recorrendo internamente ao software deste. E a chamada fonte TWAIN_32.

Comece por abrir a caixa de didogo para a seleccdo da fonte
TWAIN_32:

File > Import > Select TWAIN_32 Source...

Se tiver o scanner devidamente instalado no computador, 0 seu nome
aparecera na caixa de didogo. Seleccione-o e clique no botéo Select.

Select Source x|

Sources;

HF PrecizionScan Pro 2.0

%
Cancel |

2) Digitalizar uma imagem para dentro do Photoshop

A partir de agora, escusa de abrir 0 programa do scanner sempre que
quiser digitalizar uma imagem para dentro do Photoshop. O Photoshop fara
iSs0 por Si. Basta seleccionar:

File > Import > TWAIN_32...
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O programa do scanner paradigitalizacdo de imagens € iniciado. Nelg,
defina uma regido a volta da area que pretende capturar. Nao se preocupe com
pormenores. o refinamento seré feito no Photoshop.

Para passar aregido sel eccionada parao Photoshop, seleccione:

Digitalizar > Retornar para Photoshop

Automaticamente, a regi& agparece sobre a forma de um novo
documento e o programa do scanner para digitalizacdo de imagens é
encerrado.

Ajustes iniciais

Antes de se redimensionar e melhorar a imagem para esta poder ser
inserida na base de dados do SIFEUP, deve comecar por cortar as areas
supérfluas da digitalizacdo, tendo os seguintes cuidados:

* O fundo daimagem deve ser uniforme (por exemplo, ndo incluir o
caixilho branco das fotografias “tipo passe”);

* A largura da &ea escolhida devera ser relativamente semel hante a
atura Os procedimentos descritos a seguir ndo funcionaréo
correctamente se a largura da imagem for muito menor que a
atura

Para cortar as areas supéfluas, utilize a Crop Tool do Photoshop. Para
aceder-lhe, basta pressonar atecla‘C’. Seleccione a area de acordo com o que
foi exposto (pode gustar essa area “puxando” pelos quadradinhos que se
encontram nos seus pontos notaveis). Quando estiver satisfeito com o
resultado, clique duas vezes no interior da érea

@ Untitled-1 @ 100% (RGB)




Ficara com o documento no novo tamanho que especificou.

4) Gravar uma Action no Photoshop

Uma Action, € um conjunto de procedimentos que normalmente so
repetidos pelo utilizador. O Photoshop permite grava-los e repeti-los de uma
forma automéatica. Comece por criar uma pasta na janela Actions onde ira
gravar as suas acgoes. Para ver ajanela Actions faca:

Window > Show Actions

Nessa janela cligue no bot&o Create new set.

[ History ™ Actions ™, b
IT | E | 9 [3 Default Actions =

III'ID“IDliIﬁId

Na janela de didlogo que lhe aparecer, introduza 0 nome para a sua
pasta de actions persondizada.

Newset |

Marme: |.f-‘-.5 Minhas ACcOes| oK ) |
Cancel |




Dentro dessa pasta, podera criar uma nova action. Clique no bot&o
Create new action.

Histor ‘l Actions ™, 4
¥ | BB (O pefault Actions -

RIS /- vinves hcsies
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Na janela de didlogo que lhe aparecer, introduza o nome para a sua
action personalizada. Pressione o bot&o Record.

Mewaction |
Marne: |F|:|tDSI Record
Set: | s Minhas Accoes j Cancel

I Mane vI ™ shitt T Contral

Function key:

Color: I [ ] Mone

A partir deste momento, todos 0s seus passos serdo gravados na nova
action, O bot&o Begin recording gparece seleccionado.

Histor ‘l Actions ™,
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Se cometer algum engano nos passos que Sse seguem, pare a gravagdo
da action com o bot&o Stop playing/recording que se encontra a esquerda do
bot&o Begin recording. Arraste a linha que contém o comando a eiminar para
0 bot&o Delete: 0 mais a direita de todos. Pode depois continuar a gravagéo
pressionando o0 bot&o Begin recording.

Histor ‘l Actions ™,
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As fotos da base de dados do SIFEUP tém uma largura e uma atura
bem definidas. Comegara por definir a altura padréo para aimagem recorrendo
a0S seguintes menus:

Image > Image Size...

| Adobe Photoshop

File Edit | Image Layer Select Filker  Yiew
Mode L

Adjust k

Duplicate. ..
Apply Image. ..
Zalculations. ..

4 M
[ ﬁg* Canwas Size. ..

Zrop

Rotate Canvas k

§IT,
. * Hiskogram...
<@
& f ==

Extrack...

Al Chrl

Na janela de didlogo que aparece, comece por estipular a resolucéo da
imagem que deve ser 72 pixels/inch. De seguida, introduza o valor de 200
pixels para Height. Tenha o cuidado de verificar as opgbes Constrain
Proportions € Resample Image Bicubic.

x4
— Pixel Dimensions: 109K {was 168K
Width: 185 pizels - Cance|
- Tlqg| o
Height:  [200 | | pivets | |
Ao,
— Print Size:

Width: |6,54 | cm

[ ]%
Height:  [7.06 [ em =

Resolution: |?2 | pixelssinch j

Iv Constrain Froportions

¥ Resample Image: | Bicubic j

Cligue em OK.



Ird agora colocar a imagem padronizada também na largura. Paraisso
faca:

Image > Canvas Size...

| Adobe Photoshop

File Edit | Image Layer Seleck Filker Wi
Maode k

—
[ >

Adjust k

u }&, Duplicate. ..

= apply Image. ..
w‘;@' h Calculakions. ..
g ﬁ Image Size...
&7, f ‘?. Zrop g
é’ .\' Raotate Canvas g
;’ ; Histagrarm, ..
& f TFEEE.

Extract...  Alk+Ckrl+x

<
Js

Aparecerd uma janela de didogo que Ihe permitira cortar a imagem
paa os 140 pixels de largura Note que no procedimento anterior
redimensionou-se a imagem e aqui eliminam-se areas da imagem
respectivamente a esquerda e adireita, nas mesmas proporgoes.

Escolha Width: 140 pixels e seleccione 0 quadrado do meio do
conjunto de nove quadrados que lhe sdo apresentados. Este quadrado é o que
permite preservar a érea centra daimagem e cortar as areas laterais de modo
aque adimensdo final corresponda aos valores estipulados.

x
— Current Size: 105K
width: 185 pixels cancel [

Height: 200 pixels

— Mew Size: 55K
wtictth: |140) | pixels |
Height: [200 | pixels |
Anchor:
&
— ' -~

e




Depois destes procedimentos, a imagem ficard com as proporgdes
certas paraalargurae atura

Pode ainda melhorar-se a qualidade gera da imagem, aplicando dois
ajustes autométicos existentes no Photoshop.
Comece por fazer:

Image > Adjust > Auto Contrast

| Adobe Photoshop

File Edit | Image Layer Select Filter Wiew ‘Window Help
Mode »

) Auko Levels ShFt+iCkr+L
| he  Duplicate.. Auto Contrast  Al+ShF+CEr+L
AN Fipply In.wage... CUrvEs, ., Chrl4+-
% j Calculations. . Color Balance. ., Ctr+B
% ﬁg Image Size... BrightnessContrast, .,

.éZ’: ‘?: Era;p\-'as Sz Huej'Saturation. .. Chrl+L
Desaturate ShFt+iZkr+-
(‘5 - .\ Rotate Canvas r Replace Color. ..
& d r]:‘r i Selective Color,
y M Histogram. . Channel Mixet,..
& f, Trap... Irvvert Zhrl+I
Q Extrack...  Al+Ckrl+x Equalize
Threshald. ..
“ Poskerize, ..
Yariations. ..

De seguida, aplique 0 segundo g uste automatico:

Image > Adjust > Auto Levels



| Adobe Photoshop

File Edit | Image Layer Select Fiker Miew ‘\Window Help

. Mode: r
E Adiust Y Levels... Chri+L
; Auta Levels ShFt+Cer4-L
B[ by Duplicats... futo Contrast  Alk+Shft-+CerH+L
r':%;?, * Apply Inl'|age... Curves. ., Chrl+1
m Caleulations. . Color Balance. .. Chr+E

A imagem final aparecerd com maior contraste e com as cores
corrigidas. Embora em certas fotografias o resultado possa ser um pouco
“artificial”, no conjunto, os resultados seréo francamente positivos.

Estara agora em condigdes de gravar o ficheiro devidamente tratado.
Paraisso, faca:

File > Save a Copy...

| Adobe Photoshop

File Edit Image Laver Select Filker View v

M, , . Zhrl+1
Qper, ., kel
Qpen As, ., Ak Chrl+0
Close Chrl-Hiy
Save krl+3
Save As,., Shft+Ckrl+3

Save a Copy... Alt+CErl+5 b
Save For Web..,  &lk+ShFt+Chrl+5 ’

Ao proceder desta forma, aparecer-lhe-a uma janela de didlogo que lhe
permite escolher o directdrio onde quer colocar o ficheiro. Tenha o cuidado
de seleccionar a opgéo Save As JPEG € Use Lower Case Extension. Lembre-
se também que o nome do ficheiro deve corresponder ao nimero de aluno ou
ao nimero de funcionario.



Savejn:la'l j = £5 Ef-

990503113.jpg

File name:  |000570007.jpg Save |
5 ave fis IPEG [FJPG -+ JPE | Cancel |
g
™| Elatten | mage [T | Exclude Alpha Channels
™| Save Thumbnail [T Exclude Mon-lmage D ata

¥ Use Lower Case Extension

Clique no botdo Save. Aparecera outra janela de didogo que |he
permite configurar as opgdes para o JPEG. Aqui devera escolher Quality: 6
Medium e Format Options Baseline (“Standard”).

x
[atte: | Mone j Ok |

— Image Options Cancel |
Quality: |:5|I | Mediom =]
zrnall file large file
\ - .

— Format Options
{* Baseline ("Standard")

" Baseline Optimized
" Progressive ¥ Ereview

SEAns: I 3 vI
— Sige
~3 64K /3,345 EI 28 8Kbps vI

Faca OK. Feche o documento da imagem. Aparece a janela final que
Ihe perguntara se desgja gravar as alterages feitas. Responda No.

Adobe Photoshop

Save changes to the Adobe Photoshop docurnent
“Lintitled-1* before closing?

Yes i [u] Ig Cancel |
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Com este ultimo passo, acabou de configurar a sua action. Pare a
gravagdo com o botéo Stop playing/recording. (0 primeiro a contar da

esquerda).

Hiztor ‘l Actions ™, 4
[+ | B |b (O Default Actions -
[+ | [ |= [0 &= Minhas écgies
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|_ = Fotos
|_ [ Imnage Size
|_

? Canvas Size

B Levels

? Lewvels

? Save

u
-
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A imagem seguinte, mostra a action completa com todos os
procedimentos que foram efectuados. E desgjavel que todos os
procedimentos sgam autométicos, menos a fase em que o Photoshop
pergunta 0 nome parao ficheiro (se assm néo fosse, o Photoshop atribuiria o
mesmo nome a todas as imagens tratadas com esta action). Para que isto
acontega, devera clicar no quadradinho que se encontra a esquerda da linha

com 0 comando Save.

Histor ‘l Actions ™,

=
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P [ Default Actions -
= [0 &= Minhas dccies

= Fotos

= Image Size
Height: 200 pixels
Reszolution: 28,346 per cm
With Constrain Proportions
Interpolation: bicubic

F Canwas Size
width: 140 pixels
Horizontal: center

F Lewels
With Auto Contrast

F Lewels
Wfith Auto

T Save

Az JPES

Cuality: &

Matte: none

In: E:%Fotos 1 W00O0S 70007 jpg
With Copy

With Lower Case

Mo

Saving: no -

IR




5) Gravar um conjunto de ac¢des

Se pretender partilhar as suas ac¢bes do Photoshop com outros
utilizadores, podera gravérlas.

Seleccione o conjunto criado anteriormente “As Minhas Acgdes’ que
contém a acgdo “Fotos’. Aceda ao menu dajanela Actions e escolha a opcéo
Save Actions...

Histaor ‘l Actions ™, P“

W |[E|b [ pefaut Actions Mew Action. ..
AL MR vinos hcsies I
| B B Fotos Duplicake:
Delete
Platy

(sl [E]Of&] ]

Start Recording
Recard Sagain. ..
Insert Menu Ikem, ..
Imserk stop,.,
Insert Path

Set Cptions...
Plavback Options. ..

Clear Actions

Reset Actions

Load Actions. ..

Replace Actions. ..
e

Button Mode

Aparecerd uma janela de didlogo que lhe permitira gravar o conjunto
seleccionado para um directorio a sua escolha.

] Vecpar2002

File: narne: IAS Minhas Acciies. atn Save D I

Save hs IA.:ti.:.ns [*ATH] j Canicel

11
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6) Ler um conjunto de acc¢bes

Se pretender utilizar um conjunto de acgdes criada por outra pessoa,
podera |é&-la recorrendo a0 comando Load Actions... do menu da janela

Actions.
2 | EJ | 3 pefault Actions Mew Ackion. ..
il =| V[j Mew Set...
Edll e B Fotos Duplicate
Celete

[sl* =08 [ w]

Play

Shart Recording
Record Baai., .
Inserk Menu Ikem,. .
Inserk stopn.,.
Insert Path

Set Options. ..
Playback Opkions. ..

Clear Actions
Reset Actions

Replace Actions. .. lg

Save Ackions, ..

Button Maode

Aparecera uma janela de didogo que lhe permitird ler o conjunto
seleccionado para o Photoshop.

7) Aplicar uma action aimagens subsequentes

Para aplicar a action a imagens subsequentes, repita os passos 2 e 3
deste modulo com outras digitalizagdes e de seguida, com a sua action
seleccionada, pressione o botéo Play selection.

Histor ‘l Actions ™, 4
+ | Bl B [ pefault Actions -
+ | Bl |= [ &= Minhas acchies
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